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1 Introduction

This document describes how to install and work with the Windows Compact 7 Board Support Package
(BSP) for the phyCORE-AM3517 platform. This BSP provides a fundamental software platform for
development, deployment and execution on the phyCORE-AM3517.

The QuickStart contains instructions for:
* Host Setup
* Board Setup
* Running and Debugging Applications
* Building OS Images
* Flashing to NAND the OS (NK.bin) and bootloaders (XLDR and EBOQT)

1.1 Rapid Development Kit Documentation

This Rapid Development Kit (RDK) includes the following electronic documentation on the enclosed
phyCORE-AM3517 Rapid Development Kit CD:

* The PHYTEC phyCORE®-AM3517 Hardware Manual
e Controller User’'s Manuals and Datasheets

«  This QuickStart Instruction guide

1.2 Professional Support Packages Available

PHYTEC backs up our Rapid Development Kits with a Start-Up Guarantee. We invite you to make use of
our free Technical Support concerning installation and setup of QuickStart demos until any kit start-up
problem you might encounter is resolved. For more in-depth questions, we offer technical support
packages for purchase. Please contact our sales team at sales@phytec.com to discuss the appropriate
support option if professional support beyond installation and setup is required.

1.3 System Requirements

The following system requirements are necessary to complete this QuickStart without errors and problems.
Deviations from these requirements may suffice, or may have other work-arounds.

1.3.1 Hardware Requirements:

The following hardware components are included in the phyCORE-AM3517 WinCE Rapid Development
Kit (part number KPCM-048-W) and are necessary for completing the instructions in this QuickStart

+ phyCORE-AM3517 System on Module (Part No. PCM-048-5533ER110-1A)
* phyCORE-AM3517 Carrier Board (Part# PCM-961)

* AC adapter supplying 5 VDC /3.2A adapter, center positive

« Straight Ethernet cable

+ Serial cable (RS-232)

« USB Standard A to mini-B cable

© PHYTEC America LLC 2011 1
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1.3.2 Software Requirements:

All software required is included in the kit and are contained in:
+ PHYTECKIitCD

+  Windows Compact 7 Evaluation Kit (includes a 90-day evaluation version of Microsoft Visual
Studio 2008).

1.4 Conventions used in this QuickStart

The following is a list of the typographical conventions used in this book.

Bold Commands or other text that should be typed literally by the user

Bold Italic File and directory names

Italic Field and window names or titles, menu items, and other terms that corre-
spond to items on the PC desktop

Underline Blue Hyperlinks to documents, webpage URLs, or FTPs

<bracket red> Replace these entries with the text applicable to your system. For

instance this may be a directory name, or IP address. The entire entry,
including brackets should be replaced by the applicable text.

Fixed Width Source code listings and examples

Pay special attention to the notes set apart from the text with the following icons:

é Completion of an important part of this QuickStart.

Useful supplementary information and tips about the topic.

Estimated completion time for the following chapter.

TIME
Q This warning will help you avoid potential problems.

CAUTION

@ Helpful information for troubleshooting and resolving potential problems.
RESOLVE

© PHYTEC America LLC 2011 2
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1.5 Kit Contents

The following hardware components are included in the phyCORE-AM3517 WinCE Rapid Development
Kit (part number KPCM-048-W) and are necessary for completing the instructions in this QuickStart:

phyCORE-AM3517 System on Module (Part # PCM-048-5533ER110-1A)
phyCORE-AM3517 Carrier Board (Part # PCM-961)

Bare PCB Expansion Board (PCM-988) (optional)

AC adapter supplying 5 VDC /3.2A adapter, center positive

Straight Ethernet cable

Serial cable (RS-232)

USB Standard A to mini-B cable

SOM extraction tool

PHYTEC Kit CD

© PHYTEC America LLC 2011 3
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2 Host Setup

The phyCORE-AM3517 (PCM-048) BSP has been developed and tested under Windows 7 x64
version with Service Pack 1. The desktop PC used for development needs to be running Windows
7 (x32 or x64) with Service Pack 1. Please also remove any previous versions of Windows CE and
Visual Studio.

2.1 Installation Sequence

The following provides step-by-step instructions for installing the necessary software in the order
required.

For Visual Studio 2008 and Windows Compact7, an evaluation version of each is provided as part
of the RDK. These components may also be downloaded and installed via the following Microsoft
site:
http://www.microsoft.com/windowsembedded/en-us/downloads/download-windows-embedded-
compact-ce.aspx

It is also recommended to upgrade Visual Studio 2008 from the RTM version to the SP1 version.
Simply install the evaluation version and then use the following link to upgrade to the SP1 version:
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=10986

2.1.1 Install Visual Studio 2008

To install Visual Studio 2008 on your desktop PC insert the DVD labeled Visual Studio 2008
Professional Edition included in this kit in your DVD ROM drive. The setup should launch
automatically. If not, open a Windows Explorer window, go to your DVD drive, change to the
directory VS and start setup.exe manually.

The following screen appears:

[
#2) Visual Studio 2008 Setup

Microsoft*

® o Visual Studio 2008 Setup

1 {Install Visual Studio 2008
w Install visual Studio 2008 features and required

components.

msdn,

[ ViewReadMe | [ Bat

Fig. 2-1. Visual Studio 2008 Setup

Click on Install Visual Studio 2008 and follow the instructions of the setup program.

At this point you may install the upgrade to Service Pack 1 (SP1) via the link provided in the
previous section.

© PHYTEC America LLC 2011 4
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2.1.2 Install Windows Compact7 Platform Builder

To install the Platform Builder Plug-in for Visual Studio 2008 please insert the DVD labeled
Windows Embedded Compact 7 in your DVD drive. The setup should start automatically. If not,
open a Windows Explorer window, go to your DVD drive and start setup.exe manually.

When the dialog box allowing you to choose a Full Install versus Custom Install appears, chose
the Custom Install as this will allow you to eliminate support for unneeded processor architectures
and reduce the required disk space from 51.36GB to approximately 10 GB. De-select unwanted
features and select the ARM v7 Architecture as shown in Figure 2-2:

# Windows® Embedded Compact 7 Installation - 7.0.2698.0 [E=REE
- .
A 4 . % Windows Embedded
Customize Installation Compact 7
yj Installing
RDP RemoteFX Update
» | Initial Opticns Summary
[¥]piatform Builder RDP RemoteFX Update
Dgompact-[&st Kit This update adds RemoteFX which enables high performance

remote desktop protocol (RDP) with hardware assist. This
improves the capabilities of RDP clients that are connected to
[@]English {en-us) Documentation VDI hosts, within a Thin Client environment.

DWindDws@- Embedded Silverlight® Tocls

m

Dlapanese (ja-ip) Documentation Initial Release

Contains content which was available with the initial release of
Windows Embedded Compact 7.

@' Shared Source
DARM w5 Architecture
DARM wb Architecture
EARM w7 Architecture

il [T IMIPS T Architecture

Fig. 2-2. Compact 7 Installation

2.1.3 Install the phyCORE-AM3517 BSP

The phyCORE-AM3517 BSP source kit is required to be able to build and modify the OS design.
Once Visual Studio 2008 and Windows Compact7 have been installed per the steps above, the
source installation kit is provided as a Microsoft Installer file. The current version is labeled
phyCORE-AM3517-Compact7_BSP_Source-PD11.1.0.

© PHYTEC America LLC 2011 5
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) PHYTEC AM3517 BSP for Windows Compact7 Setup ™

Welcome to the PHYTEC
AM3517 BSP for Windows
Compact7 Setup Wizard

The Setup Wizard will install PHYTEC AM3517 BSP for
Windows Compact? on your computer, Click Mext to
continue or Cancel to exit the Setup Wizard.

[ Mext = ] [ Cancel |

&=

Fig. 2-3. BSP for Windows Compact7 Setup

2.1.4 Install the phyCORE-AM3517 SDK

The phyCORE-AM3517 SDK for Compact 7 is needed for writing target-oriented applications. It is
installed and is integrated with Visual Studio 2008 IDE and provides a new target device for code
generation. The SDK includes all headers and libraries relevant to the functionality that is included
in the demo OS image.

* Navigate to: C:\PHYTEC\phyCORE-AM3517\Compact7 BSP\SDK
*  Open the file Phytec_AM3517_sdk.msi

* Accept the default installation path:
C:\Program Files (x86)\Windows CE Tools\SDKs\Phytec AM3517_SDK

2.1.5 Host and phyCORE-AM3517 Connections

The Host development workstation is connected to the phyCORE-AM3517 platform via both a
serial cable connected to UART3 (bottom connector) and over Ethernet.

+ The serial connection is used for interacting with EBOOT during startup. The serial
connection settings are:115200 bps, 8-bit, No parity, 1 stop-bit, No flow control.

* The Ethernet connection is used for downloading and debugging images and applications.
This should be connected to a hub on the same sub-net as the Host workstation.

© PHYTEC America LLC 2011 6
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A

CAUTION

3 Board Setup
The System on Module (SOM) delivered with the Rapid Development Kit is pre-loaded in NAND
with the three software components needed to boot Windows Compact 7:

+ XLDR
« EBOOT
+ NK

In this state, EBOOT can be used to download new NK.bin images if the OS configuration is
changed. If for some reason either XLDR or EBOOT are corrupted and need to be replaced, this
can be done via a properly formatted (bootable) SD Card.

To change between booting from NAND and booting from an SD card, switches on the carrier
board are used.

3.1 Selecting Boot Modes

The boot mode is selected using switches S9 and S10 on the carrier board. This selection
identifies the location from where XLDR and EBOOT are loaded for execution.

Be careful when changing these switches as the S9 and S10 packages are rotated 180° off of
each other so the switches will be on opposite sides for both OFF and ON and count 1-4 in
different directions.

© PHYTEC America LLC 2011 7
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3.1.1 Booting from NAND Flash
To boot (XLDR and EBOOT) from NAND, use the following switch setting:

S9-1 OFF S9-2 OFF S9-3 OFF S9-4 OFF

S10-1 OFF S10-2 OFF S10-3 OFF S10-4 OFF

S9

- — :

OFF | | _ | _

510

il ¥

OFF || _ __
1 2 3 4

Fig. 3-1. NAND Switch Setting

3.1.2 Booting from SD Memory Card
To boot (XLDR and EBOOQOT) from SD card, use the switch setting:

S$9-1 OFF S9-2 ON S9-3 OFF S9-4 OFF

S10-1 ON S10-2 OFF S10-3 OFF S10-4 OFF

S9

ON

OFF

- 3
OFF | | .

1 2 3 4
Fig. 3-2. MMC Switch Setting

The SD card must be formatted so as to be bootable. The tool in the AM3517 platform directory,
TI_SDCard_boot_utility v1_0.exe, can be used to format and copy the MLO (XLDRSD.nb0
renamed per the Texas Instruments internal ROM boot code convention), EBOOTSD.nb0 and,
optionally NK.bin.

© PHYTEC America LLC 2011 8
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3.2 Configuring EBOOT

EBOOT provides various functions which can be accessed upon boot by pressing the space key at
startup.

[1] Show Current Settings

[2] Select Boot Device

[3] Select KITL (Debug) Device

[4] Network Settings

[5] Flash Management

[6] Set Device ID

[7] Save Settings

[8] Enable/Disable OAL Retail Messages

[9] Select Display Resolution

[0] Exit and Continue

3.3 Display Settings

By default the system is set to support a 3.5" QVGA TFT-LCD (resolution is 240x320 pixels) with
integrated touch (part# KLCD-011). This is a TTL-level display. There is also an optional 5" VGA
LVDS TFT-LCD display (resolution is 640x480 pixels).

The system also supports DVI in seven resolutions from 640x480 pixels to 1280x720 pixels. The
display chosen is selected via EBOOT menu item [9]. Be sure to save your changes by selecting
EBOOT menu item [7].

© PHYTEC America LLC 2011 9
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4 Running and Debugging the Sample Application

PHYTEC provides you with a simple sample application to learn about downloading code onto
your phyCORE-AM3517 device using Visual Studio 2008. The following sections also discuss how
to modify and re-build the application, as well as how to use the Visual Studio 2008 application
debugger.

4.1 Opening and Building the HelloWorld Example

The simple sample application, HelloWorld, when downloaded and executed on your device, prints
the text 'Hello World' on the display of your phyCORE-AM3517.

« To open the HelloWorld project, open Visual Studio 2008 and select
File->Open->Project/Solution from the menu bar

* Browse to the folder C:\PHYTEC\phyCORE-AM3517\Compact7 BSP\Sample
Applications\HelloWorld

» Select the HelloWorld solution
* Inthe Solution Platform pull-down menu make sure that the Phytec_AM3517_SDK

(ARMVA4I) configuration is selected and that the Phytec_AM3517_SDK ARMV?7 Device is
selected in the Target Device menu

/) HelloWarld - Microsoft Visual Studio =Tt x|
File Edit View Project Build Debug Tools Test Window Help
-i5-65H | % 59 - -5 b Debug ~ Phytec AM3517 SDK (ARW = | [# Init o e e Sl Mo

Phytec_AM3517_SDK ARMVT Devic - | g 8| 42 7

@b |iEE| = 2 3 @ B

Solution Explorer - HelloWarld + 1 %] HelloWorld.cpp) T

25 E4 (Global Scope) b T

_J Salutan HelloWoddimprojedt) CommandBar AddAdornments (g_hWndCommandBar, 0, 0); 4
7 HelloWorld ower: | ot

- [ Header Files

L [1] HelloWorldh

i i [0 Resourceh
L[] stdafoh

£ [ Resource Files

case WM_PAINT:
hdc = BeginPaint (aWnd, sps):
RECT rt:
hdc = BeginPaint (aWnd, &ps):
GetClientRect (hWnd, &rt);

[#] HelloWorld.ico DrawText (hdc, _T("Hella World"}, 12, &rt,

1 HelloWorld.rc DT_SINGLELINE | DT_VCENTER | DT_CENTER);
L. Zi HelloWorld.rc2 EndPaint (hWnd, &ps);

7 Source Files break;

&) HelloWorld.cpp case WM_DESTROY:

¢ b o stdafxcpp CommandBar Destroy(g_hWndCommandBar) ;
Lo ReadMext PostQuitMessage (0) ;
break; al
default:

return DefWindowProc (hWnd, message, wParam, lParam):

return 0;

g Soluti.. [ Catal... [@f Class . | Wind... ||| <[ n L
Output -1 x
Show outout from:_Build ~lRAlA =M=

i Code Definition Window [ 751 Call Browser| =] Output‘

Ready Ln7 Col 21 Ch2l INS

Fig. 4-1. Hello World

« Build the application by selecting Build->Build Solution

© PHYTEC America LLC 2011 10
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NOTE: There are two modes you can build in: 'Release' and 'Debug'. The Debug mode is
useful for debugging in that it turns off compiler optimizations so essentially there is a
one-to-one mapping from the source to the generated code. This way, setting a breakpoint in
the source is guaranteed to translate to some line of assembly code related to that source.

The Release version is what you would normally use when deploying your application. With
optimizations turned on your code will generally run faster. You can still use breakpoints and
debug, but the debugger will on occasion tell you it has to move your breakpoint to the next
executable instruction.

4.2 Configuring Visual Studio 2008 for Application Debugging
over Ethernet
Before being able to download to the phyCORE-AM3517 target device via Visual Studio 2008's

application debugger, an Ethernet connection between the Host and the target must be
configured. This requires two steps:

Boot the target using the OS NK.bin, that is already flashed into NAND and determine the
IP address of the device (which it obtains via DHCP)

Determine the IP address by opening a command prompt and issue the command
ipconfig /all

Inform Visual Studio 2008 to connect to this specific IP address:

From the Visual Studio IDE main menu, select Tools->Options->Device Tools->Devices. If
in the Devices window Phytec_AM3517_SDK_ARMV7 Device is not present, use the
above pull-down menu to select it.

At the right of the Devices window, select Properties.
In the Properties windows, to the right of the Transport pull-down, select Configure...

In the resulting window, select Use Specific IP address: and enter the target device's IP
address.

Select OK and continue.

© PHYTEC America LLC 2011 11
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TIP

ﬂ HelloWorld - Microsoft Visual Studio

File Edit View Project Build Debug Tools Test Window Help

B RS =R B~ A -y I = | b Debug

Phytec_AM3517_SDK (ARM - | @ Init

oD s % Bl -

 Phytec_AM3517_SDK ARMV7 Devic = | 8y & P b Ar | E

= | Options

i = Device: - 2o | 57 @ |
Solution Explorer - HelloWorld ~ 3 X HellaWorld.cop|
@5 E&

[5] Solution HelloWorld' (1 project)
= (5 HelloWorld

£+ [ Header Files
(] HelloWorld.h
~ |n] Resourceh

b

(Global Scope)
1 ConmandBax)|
break;
case WM _PAINT:

hdc = Begi;

RECT rc:
1] stdabuh ndc = Begi
= I Resource Files GetClientRy

v H] HelloWorld.ico DrawText (b

T HelloWorld.rc o]

Phytec_AM3517_SDK ARMVT Device Properties L2 =

Default output location on device:

Transport:
[7CP Connect Transport o] P ]
Bootstrapper:

[Activesyne startup Provider - Configure...

Detect when device is disconnected

Fig. 4-2. Ethernet Configuration

Environment Show devices for platform:

Projects and Solutions [Phyec AM3E17 50K

Source Control

Text Editor Devices:
Retabes Tanls
Debugging
Device Tools
General
Devices

Form Factors
HTML Designer
Office Tools
Platform Builder
Test Tools

Save As...
Rename...

Delete

Text Templating
Windows Ferms Designer

Default device:

Uokllon Deianer Phytec_AM3517_SDK ARMVT Device

=

Configure TCP/IP Transport

[7] Use fixed port number: 5655
Device IP address
() Obtain an IP address automatically using ActiveSync
©) Use specific IP address:

l 127001 -

4.3 Launching and Debugging the Demo Application

After successfully building the sample application and configuring the Ethernet connection, you
can launch the application on the device simply be selecting Build->Deploy HelloWorld.

Ch e

» To utilize the application debugger, set a breakpoint in the code and select Debug->Start
Debugging. To do this, expand the HelloWorld tree and Source Files.

*  Double-click on HelloWorld.cpp to open the file in the source code editor.

Make sure that you have selected and built the Debug version

e Scroll down in the code and locate the lines:

case WM_PAINT:
hdc =

BeginPaint (hWnd, &ps);

+ To the left of the second line, right-click and select Breakpoint->Insert Breakpoint.

© PHYTEC America LLC 2011
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r
%] HelloWarld - Microsoft Visual Stu

File Edit View Project Build Debug Tools Test Window Help
-G S| % G0 -5 | b Debug - Phytec_AM3517_SDK (ARM - | [ Init B o =
 Phytec AM3517_SDK ARMVT Devic - | 8k G [ 42 20 & [ o B ax

[ Device: - 20|57 A |2 T

Solution Explorer - HelloWorld ~ & X| HelloWorld.cpp| =X
- 2 =
28|68 (Global Scope) + % WndProc(HWND hiWnd, UINT message, WPARAM wParam, LPARAM IParam) -
[ Selution 'HelloWorld' (1 project)
7 CommandBar AddAdornments (g_hWndCommandBar, 0, 0);:
- (53 HelloWorld break: - i
- [ Header Files O
- 1] HelloWorld.h »A~ = BaginPaint (hWnd, &ps);:
[n] Resource.h Call Browser 3
.| stelafich | CreateUnitTests,,  [inPaint (hWnd, &ps);
- (&7 Resource Files ———————[Rect (hWnd, &rt):
[ HelloWorld.ico o8 GoTeDefinition hde, _T("Hello World"), 12, &zt,
- (24 HelloWorld.rc % | GoTo Declaration [DT_SINGLELINE | DT_VCENTER | DT_CENTER):
& HelloWorld.rc2 Find All References InWnd, &ps): @
- [ Source Files ) B
. & Helloworld.cpp GoToHeaderFile oy,
& stdabx.cpp Breakpoint '@ InsetBreskpoint  andBET)S
- [ ReadMetet W P——
*E | RunTo Cursor Insert Tracepoint E
cSoluti.. [ Catal.. el x| cn D 4
Output 23| Copy A
Show output from: Platform Builder Debug - A Paste
Outlining 3 =

Fig. 4-3. Insert Breakpoint

* Now select Debug->Start Debugging from the menu bar. The code will be downloaded
and launched, and will stop at the assigned breakpoint. You can then single-step by
pressing F10.
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5 Building Images

In this chapter you will learn how to use the existing sample OS design to create, download, and
run an OS image. You can also modify the existing sample OS design by adding or deleting
components from the catalog. Finally, direction is given as to how to create a new application SDK
from your modified OS design.

5.1 Building the Sample OS Design and AM3517PHYTEC BSP

The sample OS design is installed as part of the BSP installation performed in Chapter 2.1.3. To
open this OS design:

*  Open Visual Studio 2008
* From the menu bar select File->Open->Project/Solution
+  Browse to:C:\WINCE700\0SDesigns\AM3517PHYTEC\AM3517PHYTEC

*  Open the OS design project AM3517Phytec.pbxmi.

There are two ways to build, Release and Debug. Rarely is a full Debug build of the OS
required, so typically you would choose Release, in this case by selecting AM3517Phytec
ARMV7 Release from the Solution Configurations pull-down menu.

* Having selected this, you can build the OS image by selecting Build->Build
AM3517Phytec.

The full build will take 20-30 minutes depending on the OS features and the Host
performance.

5.2 Creating an OS Design Using Platform Builder

Whether creating a new OS design from scratch or modifying an existing one, the primary means
is by adding or deleting elements from the OS via the Catalog Items View window. See Figure
5-1.

With the sample OS design opened, select the Catalog Items View. As shown below, the folders of
interest are:

AM3517Phytec->Core OS->Windows Embedded Compact

* Items under Core OS are features of the OS such as ActiveSync, WordPad and USB
Host.

AM3517Phytec->Third Party->BSP->AM3517Phytec:ARMV7

* Items under BSP are mainly the device drivers provided in the PHYTEC BSP Kkit.
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&) AM3517Phytec - Microsoft Visual Studio =l x|
File Edit View Project Build Debug Target Tools Test Window Help
i - - B WO % 8 - - o~ 5L | b AM3517Phyte » Platform Builder ( TGTCPL »
o Device: AM3517 - Fu %o | P A | L

Ca!aioghems\ﬁew - 3 X

| Filter » | 2] | <Search> - &

..... -g AM3517Phytec

.1 EVM_OMAP3530:ARMVT
+|:| PowerVR
-3 Texas Instruments

hj Solution Explorer| ] Catalog Items View '22"5 Class View| Windows Embedded Events H
e { - B

Output ~ 4 x
Show output from: Platform Builder Debug L] L A s B S = |

jCcdr: Dr:fmltmn\"‘."lndCW|L"jCall Brows er. _‘| Outputl

Ready

Fig. 5-1. Catalog Iltems View

5.2.1 Modifying the Sample OS Design

You can customize what OS and BSP components are contained in your production OS image
based on the hardware and software requirements of your production device. As an example, if
none of the applications you are running use managed code, you can omit Microsoft's Compact
Framework support. There are other OS components that require a considerable amount of flash
and RAM memory so excluding unwanted features has the added benefit of reducing your
memory size requirements. Of course, not all devices will require all of the drivers supported by the
BSP.

5.2.2 Creating a New SDK for an OS Design

If you modify the sample OS Design provided in the kit, you may need to create a new SDK for
application development, as it provides the headers and libraries relevant to your particular OS
configuration.

*  With your OS configuration opened in Solution Explorer and a fresh build of your OS,
select Project->Add New SDK

+ Complete the relevant sections as needed to label and name your resulting SDK's MSI
(.msi) installer file.

* In Solution Explorer you will see your new SDK in the SDK's folder. Open this folder and
then right-click on your SDK and select Build. This will gather the needed components and
create a new MSI.
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»  Application developers can now use this SDK for development. They should first shut
down Visual Studio 2008 and then un-install any previous SDK using the Windows Control
Panel->Programs->Uninstall a program. Finally, run the new MSI file to install the new
SDK.

5.3 Downloading a New OS Image

The bootloader EBOOT is capable of downloading new bootloader and OS images. It is able to
communicate with Platform Builder to download and flash to NAND not only updated OS images,
but also the initial program loader, XLDR, and the bootloader EBOOT.

When downloading a new OS image, one can choose whether to program the OS image into the
OS partition in NAND flash, or directly to RAM. By default, OS images are built to be programmed
directly to RAM. This section describes how to use EBOOT and Platform Builder to do this, using
the image built in Chapter 5.2

5.3.1 Configuring the Bootloader to Load Image Over Ethernet

The bootloader must be configured to load an image over Ethernet. Boot the device and using the
serial connection (115200 bps, 8-bit, No parity, 1 stop-bit, No flow control) enter the EBOOT
configuration menu by pressing the space bar.

»  Select option [2] to select the boot device
» Select option [1] for internal EMAC
*  Optionally save the settings using [7]

»  Select option [0] to exit and continue

EBOOT will now attempt to obtain an IP address using DHCP. After acquiring an address it will
broadcast a "BOOTME" message that Platform Builder will recognize.

INFO: *** Device Name AM35x-59632 ***

InitDHCP():: Calling ProcessDHCP()

ProcessDHCP(): :DHCP_INIT

Got Response from DHCP server, IP address: 192.168.3.227

ProcessDHCP()::DHCP IP Address Resolved as 192.168.3.227, netmask:
255.255.255.0

Lease time: 3600 seconds

Got Response from DHCP server, IP address: 192.168.3.227

No ARP response in 2 seconds, assuming ownership of 192.168.3.227
+EbootSendBootmeAndWaitForTftp

Sent BOOTME to 255.255.255.255

Sent BOOTME to 255.255.255.255

5.3.2 Configuring Platform Builder to Connect to Target
Platform Builder must be configured to recognize and download to the target device.
* In Platform Builder, select: Target->Connectivity Options

* Using the Target Device pull-down menu, if a device for the phyCORE-AM3517 doesn't
already exist, use the Add Device menu item to create one:
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AM3517Phytec - Microsoft Visual

File Edit View Project Build Debug Target Tools Test Window Help
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- [ Parameter Files

g Soluti... [ Catal. G Class ..
'Code Definition Window
No definition selected

] _
||z Code Definition Window [s5Call Browser “zdl
| ressy 1]

Fig. 5-2. Create Target Device

«  With the Target Device selected, configure Kernel Download to be Ethernet, Kernel
Transport to be Ethernet, and Kernel Debugger to be KdStub.

* Then select the Settings tab next to Kernel Download. With the target device configured
in the previous section, you should see the device appear in the active target device
window.
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Fig. 5-3. Create Target Device

+ Selectit and click Apply then Close.

Then select Target->Attach Device. The download will begin and display a progress
window.
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6 Flashing Images To NAND

By default, OS images, NK.bin, are built to be downloaded and run from SDRAM. In order to flash
a new image to NAND, NK.bin must be built with the environment variable IMGNAND=1. This can
be done in one of two ways (assuming the OS has already been built):

If using the Visual Studio/Platform Builder IDE:

+  Set the IMGNAND environment variable equal to 1 IMGNAND = 1) using
Project->Properties->Configuration Properties->Environment

* Then select the Build->Make Run-Time Image
If building directly from a command window
»  Select Build->Open Release Directory in Build Window

* In the command window type the following commands:
set IMGNAND =1

makeimg

6.1 Flashing NK.bin with Platform Builder

Once the OS image has been configured and built for flashing to NAND, follow the directions in
Chapter 5.3 - "Downloading a New OS Image". The bootloader will automatically program NK.bin
into NAND flash.

6.2 Flashing NK.bin with SD Memory Card

To be able to flash NAND with a new NK.bin OS image using an SD card, the card must be
formatted and marked as bootable. To do this, use the software tool in the AM3517 platform
directory, TI_SDCard_boot_utility_v1_0.exe.

In addition, the following files need to be included:

* The MLO file (a renamed version of XLDRSD.nbo) which is created as part of the build
process

« EBOOTNAND.nbo which is a version of EBOOT with the ability to program NAND flash,
but must be renamed to EBOOTSD.nb0 so XLDR can locate it

* NK.bin

During booting from SD card, enter the EBOOT menu by pressing the space bar during boot. From
the main menu, select option "[2] - Select Boot device". Then configure the boot device to be "NK
from SDCard FILE".
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6.3 Flashing XLDR or EBOOT

Should it be necessary to flash to NAND either the initial bootstrap loader (XLDR) or the
bootloader (EBOQT), this can be done using a combination of an SD card, containing the version
of EBOOT that has the NAND flashing capability built into it (EBOOTNAND.nb0O) as explained in
Chapter 6.2, and Platform Builder.

1. Configure the system to boot from SD card (see Chapter 3.1 - "Selecting Boot Modes")

2. Configure an SD card and place the MLO and EBOOTNAND.nbO files on it using the tool
Tl_SDCard_boot_utility v1_0.exe as described in Chapter 3.1.2.

3. Select the image you want to download (either XLDRNAND.bin or EBOOTNAND.bin) by
selecting Project->Properties->Configuration Properties->General

ﬁg AM3517Phytec - Microsoft Visual Studio

File Edit View Project Build
@ - @ % s |9 - E - | b AM3S17Phyte + Platform Builder [ TGTCPL ~ | [ Init - | R B E
i o Device: AM3SL7 S e . W
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L =
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Debug Target Tools Test Window Help

(] Solution 'AMB3517Phytec’ (1 project)
- @ AM3517Phytec

=- & C/WINCET00
- [J platform
- [ private
- [ public

‘i:? Favorites
&1 SDKs

- [H] Subprojects

- [ Parameter Files

Commaon Properties
Build Tree (WINCEROOQT)
Configuration Properties
General
Locale
Build Options
Envirenment
Custom Build Actions
Subproject Image Settings

) Debug

Release directory:

%PBWORKSPACEROOT%\RelDirt AM3517Phytec_ARMV7_Release

Build type
@ Release

Target file name for debugger.

-]
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()
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datasync_presysgen Ist
dcom_presysgen st
directe_presysgen lst
ebootnand bin
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ebootsd bin
ie7_presysgen lst
mediaapps_presysgen st
o nk.bin
0ssvCs_presysgen Ist
ostest_presysgen st
servers_presysgen lst
shell_presysgen Ist

weeshelfe_presysgen Ist

CSoluti.. [@) Catal... [Z3Class .| Wind... |

Code Definition Window
No definition selected

xddmor bin ‘
drsd bin
wdnuart bin

< mn J L4

j_C ode Definition Window i‘;ach Browser E]_Outp ut

Ready

Fig. 6-1. Selecting the Bin File

4. Boot the system, connect to the device, and download the image as described in Chapter
5.3 - "Downloading a New OS Image".
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Appendix A: Helpful Hints and Tips

A.1 Where to Find More Information

If any additional help is required, below is a list of links that will supply additional information about
a variety of topics:

+ PHYTEC phyCORE-AM3517 Developer Wiki:
https://www.phytec.com/wiki/index.php?title=Category:PhyCORE-AM3517

« Texas Instruments Sitara Linux Wiki:
http://processors.wiki.ti.com/index.php/Category:Sitara_Linux

*  For technical support on phyCORE-AM3517, contact support@phytec.com

*  For commercial support, contact sales@phytec.com
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