kitCON-161 RI/PI

FAQ

kitCON-161 RI/PI

FlashTools3

FlashTools3: Using automatic BOOT / RESET generation.

To use the "automatic BOOT / RESET signal generation" possibility of the FlashTools3, you must intergrate the circuitry in your application as described in the attached application note.

Download: Application Note "Handshacke signals for using with FlashTools3"

FlashTools3 und USB-RS232 Adapter

Wir haben viele USB-RS232 Adapter auf die Zusammenarbeit mit unseren FlashToools3 überprüft und haben leider festgestellt, daß nicht jeder von diesen Adaptern unser Übertragungsprotokoll von den FlashTools3 umsetzt. 

Aus diesen Grund haben wir den Adapter, der einwandfrei mit unseren FlashTools3 funktioniert als Artikel für Sie eingerichtet. Sie können diesen Adapter direkt bei uns unter der Artikelnummer ZUB-007 bestellen.

phyCORE-167 HS/E: FlashTools3 Error

Question:

I am trying to complete the Blinky2 and Hello2 demos from the phyCORE-167 HS/E QuickStart guide. I am able to compile but when I try to load my hex file using FlashTools3 I get an error saying that the specified area is not blank.

Answer:

In the project Target settings, be sure that 'Use On-chip Rom' and 'Use On-chip XRAM' are NOT checked.

Keil C166

C16x Using Interrups

Question:

We are using a PHYTEC C167 Board with Keil IDE.
We are trying to use the asynchronous serial I/O on P3.11 (RxD0) and P3.10 (TxD) with using interrups.
In debug mode simulation  the interruptions work, but after loading our program into flash of the modul using the FlashTools, the interruptions don't work.
Our questions are : Why do the interruptions not work ?

Answer:

Please check, that the IE (Interrupt Enable) flag in the PSW register is set to 1.

In debug mode the IE flag will be set from monitor, because the monitor uses serial I/O with interrupts.

In stand alone mode your program must set the IE flag to use interrups.

 

Tasking C166

C16x Using Interrups

Question:

We are using a PHYTEC C167 Board with Keil IDE.
We are trying to use the asynchronous serial I/O on P3.11 (RxD0) and P3.10 (TxD) with using interrups.
In debug mode simulation  the interruptions work, but after loading our program into flash of the modul using the FlashTools, the interruptions don't work.
Our questions are : Why do the interruptions not work ?

Answer:

Please check, that the IE (Interrupt Enable) flag in the PSW register is set to 1.

In debug mode the IE flag will be set from monitor, because the monitor uses serial I/O with interrupts.

In stand alone mode your program must set the IE flag to use interrups.